Telephone Outage

Incident Report for GSU Technology Systems

Monitoring

IIT can confirm that phone services have been restored to affected numbers.

If you still are experiencing issues, please email help@gsu.edu
Posted Apr 01, 2025 - 20:30 EDT

Investigating

IIT is currently investigating reports of phone line disruptions, including issues with the GSU Police Line 3-3333 (404-413-3333), preventing calls from going through or being received.

Our team is actively working to identify the issue and resolve it as quickly as possible.

If you have an emergency, please use a mobile device to call 911.

We will provide updates as soon as more information becomes available.
Posted Apr 01, 2025 - 19:16 EDT
This incident affects: Telephone System.