Duo Authentication Issues Reported

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 08:23 EST

Monitoring

The vendor is seeing successful SMS and Phone Call Delivery for GSU users and will continue to monitor the situation.

If the DUO issue still persists for your account on Friday-Feb. 14th, then please submit a new incident to help.gsu.edu, help@gsu.edu or give us a call at 404-413-4357(HELP).
Posted Feb 13, 2025 - 17:54 EST

Identified

Identified - The vendor has identified the issue causing Admin Panel login, Device Management Portal, Risk-based Authentication, and SMS/Phone Call delivery failures across all deployments and are working to deploy a fix.

Please continue to check here for more updates.
Posted Feb 13, 2025 - 14:10 EST

Investigating

Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with successful DUO authentications.

Users are either receiving a DUO error or unable to authenticate.

Additional information will be posted here on status.gsu.edu when the issue is confirmed.
Posted Feb 13, 2025 - 13:29 EST
This incident affected: Duo MFA.